Scheduled Maintenance - 9:30 AM ET

Incident Report for SX.bet

Resolved

This incident has been resolved.
Posted May 08, 2026 - 10:05 EDT

Investigating

Please be advised we’ll be performing a planned infrastructure upgrade at 9:30 AM ET. Betting will be temporarily disabled for 30 minutes during the maintenance window and will be re-enabled once complete, potentially earlier.

Thanks for your patience.
Posted May 08, 2026 - 09:18 EDT
This incident affected: API.