Scheduled Maintenance - March 2nd

Incident Report for SX.bet

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 12:45 EST

Investigating

Please note that SX.Bet will undergo a scheduled system upgrade on Monday, March 2nd, 2026, between 9:00 AM and 1:00 PM ET.
Betting will be temporarily unavailable during this maintenance window. We appreciate your patience as we complete this upgrade to improve platform performance and reliability.
Posted Feb 24, 2026 - 11:50 EST
This incident affected: API.