Scheduled Maintenance - April 7 at 10:00 AM ET

Incident Report for SX.bet

Resolved

SX.Bet is now fully operational following the scheduled system upgrade.
Posted Apr 07, 2026 - 10:05 EDT

Investigating

Please note that SX.Bet will undergo a scheduled system upgrade tomorrow (Tuesday, March 2nd, 2026) between 10:00 AM and 10:30 AM ET.

Betting will be temporarily unavailable during this maintenance window. We appreciate your patience as we complete this upgrade to improve platform performance and reliability.
Posted Apr 06, 2026 - 09:49 EDT
This incident affected: API.