Betting Disabled

Incident Report for SX.bet

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 12:44 EDT

Investigating

Betting is disabled as we investigate an issue impacting confirmation of bets.
Posted Aug 27, 2025 - 10:28 EDT
This incident affected: API.